#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\s*)(.*),?\n"
Local $sString = "MERGE" & @CRLF & _
" market-data-351917.cobi_live_analytics.staging_blackrock_benchmark_security AS TARGET" & @CRLF & _
"USING" & @CRLF & _
" (" & @CRLF & _
" SELECT" & @CRLF & _
" security_id," & @CRLF & _
" effective_begin_timestamp," & @CRLF & _
" etl_job_id," & @CRLF & _
" record_digest," & @CRLF & _
" benchmark_source_name," & @CRLF & _
" corporate_benchmark_flag," & @CRLF & _
" corporate_benchmark_weight," & @CRLF & _
" investment_grade_flag," & @CRLF & _
" high_yield_flag" & @CRLF & _
" FROM" & @CRLF & _
" market-data-351917.cobi_live_analytics.security_corporate_benchmark_attributes AS a" & @CRLF & _
" LEFT JOIN (" & @CRLF & _
" SELECT" & @CRLF & _
" security_id," & @CRLF & _
" corporate_benchmark_effective_begin_timestamp," & @CRLF & _
" corporate_benchmark_record_digest" & @CRLF & _
" FROM" & @CRLF & _
" market-data-351917.cobi_live_analytics.security_current) AS b" & @CRLF & _
" USING" & @CRLF & _
" (security_id)" & @CRLF & _
" WHERE" & @CRLF & _
" a.corporate_benchmark_flag = TRUE" & @CRLF & _
" AND a.effective_begin_timestamp = b.corporate_benchmark_effective_begin_timestamp" & @CRLF & _
" AND a.benchmark_source_name = 'us_corporate_bond_ucits_etf') AS SOURCE" & @CRLF & _
"ON" & @CRLF & _
" target.security_id = source.security_id" & @CRLF & _
" WHEN NOT MATCHED" & @CRLF & _
" THEN" & @CRLF & _
"INSERT" & @CRLF & _
" (security_id," & @CRLF & _
" effective_begin_timestamp," & @CRLF & _
" etl_job_id," & @CRLF & _
" corporate_benchmark_record_digest," & @CRLF & _
" benchmark_source_name," & @CRLF & _
" corporate_benchmark_flag," & @CRLF & _
" corporate_benchmark_weight," & @CRLF & _
" investment_grade_flag," & @CRLF & _
" high_yield_flag)" & @CRLF & _
"VALUES" & @CRLF & _
" (source.security_id, source.effective_begin_timestamp, source.etl_job_id, source.record_digest, source.benchmark_source_name, FALSE, source.corporate_benchmark_weight, source.investment_grade_flag, source.high_yield_flag)" & @CRLF & _
""
Local $sSubst = "$1"$2 "\\\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)