$re = '/[,.-_]?[ء-یa-zA-Z0-9]+[,.-_]?/m';
$str = 'اصفهان، سه راه سیمین، خ سهروردی، خ رودکی، ک شهید امینی، بن بست نوید، پلاک 387';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);