import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(\\s*[0-9]+\\s*),(\\s*[0-9]+\\s*)\\]\\s*(>=|<=|==|>|<)\\s*([0-9]+)\\s*(\\|\\||\\&\\&)*";
final String string = "[1,2]==3 || [1,110] >= 2 && [1,200] > 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}