using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{3}.*|^\(.*|^1\s.*)";
string input = @"415-555-1234
650-555-2345
(416)555-3456
202 555 4567
4035555678
1 416 555 9292";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}