re = /[#%“”&*|\-:"<>?\/\\]/
str = '(-).(%)“”(&)(*).(|).(\\)-(:).(").(<).(>).(?).(/)1#[^\\/]+\\/$'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result