package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{13}$`)
var str = `5914631000012`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}