package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.set\((.+,\s?){2}(.+)\)`)
var str = `m.set("foo",BAR, true)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}