#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)passengers\*\s+?(?<TotalPrice>[0-9\,\.]{5,8})|Total\*\s+?([0-9\,\.]{5,8})"
Local $sString = "E-Ticket Itinerary, Receipt and Tax Invoice" & @CRLF & _
"" & @CRLF & _
"Your Booking Reference" & @CRLF & _
"" & @CRLF & _
"KTHQEJ" & @CRLF & _
"Important Information" & @CRLF & _
"• This is your E-Ticket Itinerary & Receipt/Tax Invoice. We recommend that you print this out or save this on your phone, and it" & @CRLF & _
"is recommended you retain a copy for your records." & @CRLF & _
"• Each passenger travelling needs a printed copy of this document for airport security checks." & @CRLF & _
"• Please familiarise yourself with the key Conditions of Carriage, Dangerous Goods guide and other information attached." & @CRLF & _
"Passenger Ticket Information" & @CRLF & _
"Passenger Name" & @CRLF & _
"" & @CRLF & _
"Frequent Flyer No." & @CRLF & _
"" & @CRLF & _
"Ticket No." & @CRLF & _
"" & @CRLF & _
"Issued" & @CRLF & _
"" & @CRLF & _
"Mr Zachary Kirkham" & @CRLF & _
"" & @CRLF & _
"QF1752890" & @CRLF & _
"Qantas Club Silver / oneworld Ruby" & @CRLF & _
"" & @CRLF & _
"081-2301896427" & @CRLF & _
"" & @CRLF & _
"04 Dec 19" & @CRLF & _
"" & @CRLF & _
"Ticket Total*" & @CRLF & _
"814.07" & @CRLF & _
"" & @CRLF & _
"Mr Matthew Davis" & @CRLF & _
"" & @CRLF & _
"QF1911660387" & @CRLF & _
"Frequent Flyer Silver / oneworld Ruby" & @CRLF & _
"" & @CRLF & _
"081-2301896426" & @CRLF & _
"" & @CRLF & _
"04 Dec 19" & @CRLF & _
"" & @CRLF & _
"814.07" & @CRLF & _
"" & @CRLF & _
"Ticket Total for all passengers*" & @CRLF & _
"" & @CRLF & _
"1,628.14" & @CRLF & _
"" & @CRLF & _
"*Amounts are displayed in AUD (AUD)" & @CRLF & _
"" & @CRLF & _
"Your Itinerary" & @CRLF & _
"Date" & @CRLF & _
"" & @CRLF & _
"Flight Number" & @CRLF & _
"" & @CRLF & _
"Departing" & @CRLF & _
"" & @CRLF & _
"Arriving" & @CRLF & _
"" & @CRLF & _
"Status" & @CRLF & _
"" & @CRLF & _
"Flight Information" & @CRLF & _
"" & @CRLF & _
"09 Dec 19" & @CRLF & _
"" & @CRLF & _
"QF471" & @CRLF & _
"" & @CRLF & _
"Sydney" & @CRLF & _
"0615, 6:15AM" & @CRLF & _
"Terminal 3" & @CRLF & _
"" & @CRLF & _
"Melbourne" & @CRLF & _
"0750, 7:50AM" & @CRLF & _
"09 Dec 19" & @CRLF & _
"Terminal 1" & @CRLF & _
"" & @CRLF & _
"Economy" & @CRLF & _
"Confirmed" & @CRLF & _
"" & @CRLF & _
"Est journey Time: 01:35" & @CRLF & _
"Non-Stop" & @CRLF & _
"Aircraft Type: Boeing 737" & @CRLF & _
"" & @CRLF & _
"11 Dec 19" & @CRLF & _
"" & @CRLF & _
"QF434" & @CRLF & _
"" & @CRLF & _
"Melbourne" & @CRLF & _
"1300, 1:00PM" & @CRLF & _
"Terminal 1" & @CRLF & _
"" & @CRLF & _
"Sydney" & @CRLF & _
"1425, 2:25PM" & @CRLF & _
"11 Dec 19" & @CRLF & _
"Terminal 3" & @CRLF & _
"" & @CRLF & _
"Economy" & @CRLF & _
"Confirmed" & @CRLF & _
"" & @CRLF & _
"Est journey Time: 01:25" & @CRLF & _
"Non-Stop" & @CRLF & _
"Aircraft Type: Boeing 737" & @CRLF & _
"" & @CRLF & _
"Payment Details" & @CRLF & _
"Date" & @CRLF & _
"" & @CRLF & _
"Payment Type" & @CRLF & _
"" & @CRLF & _
"Reference" & @CRLF & _
"" & @CRLF & _
"04 Dec 19" & @CRLF & _
"" & @CRLF & _
"American Express" & @CRLF & _
"" & @CRLF & _
"xxxx-xxxx-xxxx-2006" & @CRLF & _
"" & @CRLF & _
"Amount*" & @CRLF & _
"1,628.14" & @CRLF & _
"" & @CRLF & _
"This may appear as multiple transactions on your credit card statement" & @CRLF & _
"" & @CRLF & _
"Your Receipt Details" & @CRLF & _
"Ticket Charges" & @CRLF & _
"Total*" & @CRLF & _
"Card Payment Fee" & @CRLF & _
"" & @CRLF & _
"Total Amount Payable*" & @CRLF & _
"" & @CRLF & _
"Charges" & @CRLF & _
"1,465.04" & @CRLF & _
"15.10" & @CRLF & _
"" & @CRLF & _
"GST" & @CRLF & _
"" & @CRLF & _
"Total*" & @CRLF & _
"" & @CRLF & _
"1,480.14" & @CRLF & _
"" & @CRLF & _
"148.00" & @CRLF & _
"" & @CRLF & _
"1,628.14" & @CRLF & _
"" & @CRLF & _
"*Includes Taxes/Fees/carrier Charges" & @CRLF & _
"" & @CRLF & _
"Tax Information" & @CRLF & _
"GST is included for taxable sales" & @CRLF & _
"ABN:58084409316" & @CRLF & _
"" & @CRLF & _
"Issued by" & @CRLF & _
"Qantas Airways on 04 Dec 19" & @CRLF & _
"" & @CRLF & _
"GST Paid 148.00" & @CRLF & _
"" & @CRLF & _
"Flying With Us" & @CRLF & _
"Before Check-in" & @CRLF & _
"• Ensure that each passenger" & @CRLF & _
"carries a printed copy of this" & @CRLF & _
"document when travelling." & @CRLF & _
"• Label your bags inside and out" & @CRLF & _
"with your name, address and" & @CRLF & _
"contact number at your" & @CRLF & _
"destination." & @CRLF & _
"• Check Carry-on baggage and" & @CRLF & _
"checked baggage allowances as" & @CRLF & _
"restrictions apply." & @CRLF & _
"" & @CRLF & _
"Getting Away On Time" & @CRLF & _
"• Ensure you are at the airport with" & @CRLF & _
"enough time to complete necessary" & @CRLF & _
"check-in, security screening and," & @CRLF & _
"for international flights, customs" & @CRLF & _
"and immigration." & @CRLF & _
"• Familiarise yourself with the checkin and boarding times. Information" & @CRLF & _
"for Qantas and QantasLink flights is" & @CRLF & _
"in the Travel Information section" & @CRLF & _
"attached." & @CRLF & _
"" & @CRLF & _
"Check-in" & @CRLF & _
"• Visit qantas.com/checkin to" & @CRLF & _
"choose the check-in option best" & @CRLF & _
"for you." & @CRLF & _
"" & @CRLF & _
"Fare Restrictions - Refer to the applicable fare rules as special conditions may apply" & @CRLF & _
"Additional Fees: Fees may apply to some booking changes, ticket reissues and consultant-assisted services. Details are available at qantas.com." & @CRLF & _
"" & @CRLF & _
"Qantas Airways Limited ABN 16 009 661 901, 10 Bourke Road, Mascot NSW 2020, Australia" & @CRLF & _
"qantas.com" & @CRLF & _
"" & @CRLF & _
"Travel Information" & @CRLF & _
"Qantas Group check-in times" & @CRLF & _
"" & @CRLF & _
"International Terminal" & @CRLF & _
"" & @CRLF & _
"Domestic Terminal" & @CRLF & _
"" & @CRLF & _
"Australian and New Zealand Terminals**" & @CRLF & _
"" & @CRLF & _
"QF 001 - 399" & @CRLF & _
"" & @CRLF & _
"QF400 and above" & @CRLF & _
"" & @CRLF & _
"International First / Business" & @CRLF & _
"International Economy / Premium Economy" & @CRLF & _
"" & @CRLF & _
"Closes 60 minutes before departure" & @CRLF & _
"Closes 90 minutes before departure" & @CRLF & _
"" & @CRLF & _
"Domestic Business / Economy" & @CRLF & _
"" & @CRLF & _
"Closes 60 minutes before departure" & @CRLF & _
"" & @CRLF & _
"Qantas codeshare services (QF Flight" & @CRLF & _
"numbers operated by Jetstar)^" & @CRLF & _
"Jetstar Services^" & @CRLF & _
"" & @CRLF & _
"Check in opens 3 hours before departure" & @CRLF & _
"Closes 60 minutes before departure" & @CRLF & _
"JQ 001 - 399 and 3K 500 - 699^" & @CRLF & _
"" & @CRLF & _
"N/A" & @CRLF & _
"N/A" & @CRLF & _
"45 minutes from departure* Closes 30" & @CRLF & _
"minutes before departure." & @CRLF & _
"Check in opens 2 hours before departure" & @CRLF & _
"Closes 30 minutes before departure" & @CRLF & _
"JQ 400 and above" & @CRLF & _
"" & @CRLF & _
"Jetstar Business / Economy (JQ)^" & @CRLF & _
"" & @CRLF & _
"Check in opens 3 hours before departure" & @CRLF & _
"Closes 60 minutes before departure" & @CRLF & _
"Check in opens 2 hours before departure" & @CRLF & _
"" & @CRLF & _
"Check in opens 2 hours before departure" & @CRLF & _
"Closes 30 minutes before departure" & @CRLF & _
"N/A" & @CRLF & _
"" & @CRLF & _
"Jetstar flights operated by Jetstar Asia (3K)~" & @CRLF & _
"" & @CRLF & _
"* Check-in closes 30 minutes before departure. Boarding will commence 20 minutes prior to departure. ** Please check with your local Qantas office for check-in" & @CRLF & _
"time at all non-Australian / New Zealand ports. Ensure you adhere to check-in times or your fare may be forfeited." & @CRLF & _
"^ Jetstar flights JQ1-JQ399 depart from international terminals, except JQ61, JQ73 and JQ81 which depart from domestic terminals." & @CRLF & _
"~ Jetstar flights that operate under a 3K flight number between Perth and Singapore and Singapore and Auckland check-in opens 3 hours prior to departure and" & @CRLF & _
"closes 1 hour prior to departure." & @CRLF & _
"" & @CRLF & _
"Included and Carry On Baggage" & @CRLF & _
"" & @CRLF & _
"QF471" & @CRLF & _
"" & @CRLF & _
"Sydney to Melbourne - 09 Dec 2019" & @CRLF & _
"PASSENGER" & @CRLF & _
"" & @CRLF & _
"Mr Zachary" & @CRLF & _
"Kirkham" & @CRLF & _
"" & @CRLF & _
"INCLUDED CHECKED BAGGAGE" & @CRLF & _
"(no single piece may exceed 32kg / 67lb)" & @CRLF & _
"" & @CRLF & _
"PURCHASED BAGGAGE" & @CRLF & _
"(no single piece may exceed 32kg / 67lb)" & @CRLF & _
"" & @CRLF & _
"CARRY ON BAGGAGE" & @CRLF & _
"(Up to 10kg(22lb) for one piece, max 14kg(30lb) total)" & @CRLF & _
"" & @CRLF & _
"1 x 32kg/70lb" & @CRLF & _
"" & @CRLF & _
"1 x 32kg/70lb" & @CRLF & _
"" & @CRLF & _
"Cabin bag combination + 1 personal item" & @CRLF & _
"" & @CRLF & _
"1 x 32kg/70lb" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Cabin bag combination + 1 personal item" & @CRLF & _
"" & @CRLF & _
"Silver QC - 1752890 Adult" & @CRLF & _
"" & @CRLF & _
"Mr Matthew Davis" & @CRLF & _
"Silver - 1911660387 Adult" & @CRLF & _
"" & @CRLF & _
"Domestic Economy Checked + Carry On baggage information" & @CRLF & _
"CHECKED BAGGAGE" & @CRLF & _
"" & @CRLF & _
"CARRY ON" & @CRLF & _
"" & @CRLF & _
"+" & @CRLF & _
"" & @CRLF & _
"L + H + D = 140cm/54in" & @CRLF & _
"No single item of checked" & @CRLF & _
"baggage may exceed 32kg" & @CRLF & _
"(70lb). Dimensions for" & @CRLF & _
"checked baggage are" & @CRLF & _
"calculated by adding" & @CRLF & _
"together the width, height" & @CRLF & _
"and depth of the piece of" & @CRLF & _
"baggage. For tickets" & @CRLF & _
"containing a flight to or from" & @CRLF & _
"the Americas, the amount is" & @CRLF & _
"the total of all the baggage" & @CRLF & _
"added together." & @CRLF & _
"" & @CRLF & _
"Carry-on baggage varies depending on destination, class of travel or aircraft. One small personal item could be a" & @CRLF & _
"handbag, laptop computer or overcoat. Restrictions on height, depth, length and weight apply to carry-on" & @CRLF & _
"baggage. More information is on the Carry-on Baggage page." & @CRLF & _
"" & @CRLF & _
"Qantas Airways Limited ABN 16 009 661 901, 10 Bourke Road, Mascot NSW 2020, Australia" & @CRLF & _
"qantas.com" & @CRLF & _
"" & @CRLF & _
"QF434" & @CRLF & _
"" & @CRLF & _
"Melbourne to Sydney - 11 Dec 2019" & @CRLF & _
"PASSENGER" & @CRLF & _
"" & @CRLF & _
"Mr Zachary" & @CRLF & _
"Kirkham" & @CRLF & _
"" & @CRLF & _
"INCLUDED CHECKED BAGGAGE" & @CRLF & _
"(no single piece may exceed 32kg / 67lb)" & @CRLF & _
"" & @CRLF & _
"PURCHASED BAGGAGE" & @CRLF & _
"(no single piece may exceed 32kg / 67lb)" & @CRLF & _
"" & @CRLF & _
"CARRY ON BAGGAGE" & @CRLF & _
"(Up to 10kg(22lb) for one piece, max 14kg(30lb) total)" & @CRLF & _
"" & @CRLF & _
"1 x 32kg/70lb" & @CRLF & _
"" & @CRLF & _
"1 x 32kg/70lb" & @CRLF & _
"" & @CRLF & _
"Cabin bag combination + 1 personal item" & @CRLF & _
"" & @CRLF & _
"1 x 32kg/70lb" & @CRLF & _
"" & @CRLF & _
"-" & @CRLF & _
"" & @CRLF & _
"Cabin bag combination + 1 personal item" & @CRLF & _
"" & @CRLF & _
"Silver QC - 1752890 Adult" & @CRLF & _
"" & @CRLF & _
"Mr Matthew Davis" & @CRLF & _
"Silver - 1911660387 Adult" & @CRLF & _
"" & @CRLF & _
"Domestic Economy Checked + Carry On baggage information" & @CRLF & _
"CHECKED BAGGAGE" & @CRLF & _
"" & @CRLF & _
"CARRY ON" & @CRLF & _
"" & @CRLF & _
"+" & @CRLF & _
"" & @CRLF & _
"L + H + D = 140cm/54in" & @CRLF & _
"No single item of checked" & @CRLF & _
"baggage may exceed 32kg" & @CRLF & _
"(70lb). Dimensions for" & @CRLF & _
"checked baggage are" & @CRLF & _
"calculated by adding" & @CRLF & _
"together the width, height" & @CRLF & _
"and depth of the piece of" & @CRLF & _
"baggage. For tickets" & @CRLF & _
"containing a flight to or from" & @CRLF & _
"the Americas, the amount is" & @CRLF & _
"the total of all the baggage" & @CRLF & _
"added together." & @CRLF & _
"" & @CRLF & _
"Carry-on baggage varies depending on destination, class of travel or aircraft. One small personal item could be a" & @CRLF & _
"handbag, laptop computer or overcoat. Restrictions on height, depth, length and weight apply to carry-on" & @CRLF & _
"baggage. More information is on the Carry-on Baggage page." & @CRLF & _
"" & @CRLF & _
"Qantas Airways Limited ABN 16 009 661 901, 10 Bourke Road, Mascot NSW 2020, Australia" & @CRLF & _
"qantas.com" & @CRLF & _
"" & @CRLF & _
"Travel Information" & @CRLF & _
"Important Information" & @CRLF & _
"Dimensions:" & @CRLF & _
"International Flights (excluding North and South America):" & @CRLF & _
"Total dimensions for each piece must not exceed 158cm (62in). Dimensions for checked baggage are calculated by adding" & @CRLF & _
"together the width, height and depth of the piece of baggage." & @CRLF & _
"International Flights to and from North & South America:" & @CRLF & _
"Total dimensions of the 3 pieces must not exceed 405cm (159in) and total dimensions of the 2 pieces must not exceed" & @CRLF & _
"270cm (106in) with no single piece exceeding 158cm (62in). Dimensions for checked baggage are calculated by adding together" & @CRLF & _
"the width, height and depth of the piece of baggage." & @CRLF & _
"Domestic Flights:" & @CRLF & _
"Total dimensions of each piece must not exceed 140cm (55in). Dimensions for checked baggage are calculated by adding" & @CRLF & _
"together the width, height and depth of the piece of baggage." & @CRLF & _
"+Adults travelling with an infant (under 2 years) on Qantas operated services may check-in up to three infant items" & @CRLF & _
"free of charge. See here for more details." & @CRLF & _
"Interline travel: Qantas baggage allowance may not apply. If your travel on this ticket involves more than one" & @CRLF & _
"airline, the baggage allowance of the most significant carrier in your itinerary will apply to each journey, except in" & @CRLF & _
"relation to travel to, from or within the USA. Under US DOT regulations, if your travel to, from or within the USA" & @CRLF & _
"involves more than one airline, the baggage rules of one airline will apply to all of the flights in your itinerary. This is" & @CRLF & _
"determined by the first carrier in your itinerary. For travel between Australia and the USA, usually (both not always)" & @CRLF & _
"Qantas' baggage allowance will apply to the whole itinerary." & @CRLF & _
"Member Allowances: Qantas Frequent Flyer and Qantas Club member baggage allowances apply to travel on" & @CRLF & _
"Qantas and QantasLink operated flights with a QF flight number on your ticket, excluding flights to or from Lord Howe" & @CRLF & _
"Island and Mount Hotham. These allowances also apply to Emirates operated flights with an EK flight number" & @CRLF & _
"between and within Europe, the Middle East, North Africa, Asia and Australia. These benefits are not cumulative." & @CRLF & _
"Definitions: Domestic travel is travel that is not combined with any international flights on the same ticket." & @CRLF & _
"International travel is travel between two or more countries including any flight within those countries if it is combined" & @CRLF & _
"with the international travel." & @CRLF & _
"General: No single item of checked baggage may exceed 32kg (70lb). Carriage of baggage is subject to space availability and" & @CRLF & _
"any applicable aircraft weight restrictions, which vary. Baggage exceeding the specified allowance may need to be" & @CRLF & _
"accommodated on a later flight." & @CRLF & _
"Visit qantas.com/baggage or the "Planning & Booking - Baggage" page of jetstar.com for important information" & @CRLF & _
"regarding baggage restrictions. For additional and excess baggage rates visit qantas.com/additionalbaggage or" & @CRLF & _
"jetstar.com." & @CRLF & _
"" & @CRLF & _
"Qantas Airways Limited ABN 16 009 661 901, 10 Bourke Road, Mascot NSW 2020, Australia" & @CRLF & _
"qantas.com" & @CRLF & _
"" & @CRLF & _
"Travel Information" & @CRLF & _
"Enhanced Security Screening - Powders, Liquids, aerosols and gels" & @CRLF & _
"Enhanced security measures apply to and from Australia and on domestic" & @CRLF & _
"sectors of international flights within Australia. Similar or more restrictive" & @CRLF & _
"measures may apply for other countries. If you want to take powders, liquids," & @CRLF & _
"aerosols or gels through the screening point, make sure:" & @CRLF & _
"• each item is 100ml or less;" & @CRLF & _
"• all items fit comfortably in a transparent resealable 1 litre plastic" & @CRLF & _
"bag (only 1 bag per person is allowed)" & @CRLF & _
"" & @CRLF & _
"Travelling with Money" & @CRLF & _
"Are you planning to carry funds in or out of Australia? By law, you must now:" & @CRLF & _
"• If asked by a Customs or police officer, report travellers" & @CRLF & _
"cheques, cheques, money orders or any other bearer" & @CRLF & _
"negotiable instruments of any amount." & @CRLF & _
"• Always report A$10,000 cash or more (or foreign currency" & @CRLF & _
"equivalent) using a form available from Customs." & @CRLF & _
"Visit www.austrac.gov.au for more information." & @CRLF & _
"" & @CRLF & _
"Exceptions:Prescription and non-prescription medicines and baby products" & @CRLF & _
"that you need for the flight, but please note:" & @CRLF & _
"• proof of need may be required, and" & @CRLF & _
"• additional security checks may be performed" & @CRLF & _
"• All powders must be screened separately with restrictions on" & @CRLF & _
"the carriage of inorganic powders over 350 millilitres (350" & @CRLF & _
"grams)" & @CRLF & _
"" & @CRLF & _
"Qantas Privacy Collection Notice" & @CRLF & _
"Qantas collects information about you (including health information where" & @CRLF & _
"necessary) to provide products and services to you, facilitate your" & @CRLF & _
"participation in our and other organisations' loyalty programs, ensure the" & @CRLF & _
"safety and security of all passengers when travelling with us, conduct" & @CRLF & _
"marketing activities for our and third parties' products and services and" & @CRLF & _
"conduct market research." & @CRLF & _
"" & @CRLF & _
"Note - Duty Free items: Duty free liquids, aerosols and gels not exceeding" & @CRLF & _
"100ml per item may be taken onboard in your transparent resealable 1 litre" & @CRLF & _
"plastic bag. Government screening requirements vary between countries" & @CRLF & _
"around the world, and duty free liquids, aerosols and gels which exceed" & @CRLF & _
"100ml may not always be permitted through a screening point at all airports on" & @CRLF & _
"your journey. If your journey includes a flight with a transit stop or a transfer" & @CRLF & _
"to an onward connecting flight, you may be required to take these items" & @CRLF & _
"through the transit or transfer screening points where you may be required to" & @CRLF & _
"surrender the item, and it will not be returned to you." & @CRLF & _
"" & @CRLF & _
"We may collect your personal information from people who make or update" & @CRLF & _
"your travel booking or otherwise interact with us on your behalf, from our" & @CRLF & _
"related bodies corporate and Jetstar branded entities, from our service" & @CRLF & _
"providers and from immigration, customs, border security and other regulatory" & @CRLF & _
"authorities. Some of the information we collect is required under the Customs" & @CRLF & _
"Act 1901 (Cth). If the information is not provided, we may not be able to" & @CRLF & _
"provide the service requested." & @CRLF & _
"" & @CRLF & _
"Qantas recommends that you visit "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")