using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\()?\d{3}(\))?(-|\s)?[2-9]{1}\d{2}(-|\s)\d{4}$";
string input = @"(789) 456-1230";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}