package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([1-9]\d*(?:[\s\.]\d+)*)\s*(€|euros|eur|FF|FRF|francs|F)?`)
var str = ` 10 000 200 €`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}