#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((https|http):\/\/)?([a-z0-9@:%._\+~#=]{1,256}\.)+[a-z0-9:()]{1,20}+(\/[a-z0-9_():@.]+)*(\/)?((\?|#).*)?|(website_not_available))"
Local $sString = "http://foo.com/blah_blah" & @CRLF & _
"http://foo.com/blah_blah/" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)_(again)" & @CRLF & _
"http://www.example.com/wpstyle/?p=364" & @CRLF & _
"https://www.example.com/foo/?bar=baz&inga=42&quux" & @CRLF & _
"http://✪df.ws/123" & @CRLF & _
"www.https//:fgdv.com" & @CRLF & _
"test.https://www.xflowpay.com" & @CRLF & _
"http://fr.wikipedia.org/wiki/%C3%89l%C3%A9phant" & @CRLF & _
"www.exldfcsdf/dcsdfv" & @CRLF & _
"http://userid:password@example.com:8080" & @CRLF & _
"http://userid:password@example.com:8080/" & @CRLF & _
"http://userid@example.com" & @CRLF & _
"http://userid@example.com/" & @CRLF & _
"http://userid@example.com:8080" & @CRLF & _
"http://userid@example.com:8080/" & @CRLF & _
"http://userid:password@example.com" & @CRLF & _
"http://userid:password@example.com/" & @CRLF & _
"http://142.42.1.1/" & @CRLF & _
"http://142.42.1.1:8080/" & @CRLF & _
"http://➡.ws/䨹" & @CRLF & _
"http://www.mysite.com/myresumé.html" & @CRLF & _
"http://foo.com/blah_(wikipedia)#cite-1" & @CRLF & _
"http://foo.com/blah_(wikipedia)_blah#cite-1 " & @CRLF & _
"http://code.google.com/events/#&product=browser" & @CRLF & _
"http://foo.com/unicode_(✪)_in_parens" & @CRLF & _
"http://foo.com/(something)?after=parens" & @CRLF & _
"http://code.google.com/events/#&product=browser" & @CRLF & _
"ftp://foo.bar/baz" & @CRLF & _
"http://j.mp" & @CRLF & _
"http://foo.bar/?q=Test%20URL-encoded%20stuff" & @CRLF & _
"http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com " & @CRLF & _
"http://1337.net" & @CRLF & _
"http://a.b-c.de" & @CRLF & _
"http://223.255.255.254" & @CRLF & _
"https://foo_bar.example.com/" & @CRLF & _
"" & @CRLF & _
"https://regex101.com/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://" & @CRLF & _
"http://." & @CRLF & _
"http://../" & @CRLF & _
"http://##" & @CRLF & _
"///a" & @CRLF & _
"http:///a" & @CRLF & _
"foo.com" & @CRLF & _
"rdar://1234" & @CRLF & _
"http:// shouldfail.com" & @CRLF & _
"h://test" & @CRLF & _
"http://foo.bar/foo(bar)baz quux" & @CRLF & _
"http://10.1.1.255" & @CRLF & _
"http://-a.b.co" & @CRLF & _
"http://a.b--c.de/" & @CRLF & _
"ftps://foo.bar/" & @CRLF & _
"http://3628126748" & @CRLF & _
"http://.www.foo.bar./" & @CRLF & _
"http://www.foo.bar./" & @CRLF & _
"http://.www.foo.bar/" & @CRLF & _
"http://10.1.1.254" & @CRLF & _
"dc" & @CRLF & _
"dvxdc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")