$re = '/...\w?/m';
$str = 'bat
cat
data
eat
fast
12_6
$%#$@
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);