import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Za-z0-9!#$%&'*+\\/=?^_`\\{|\\}~-]+(?:\\.[a-z0-9!#$%&'*+\\/=?^_`\\{|\\}~-]+)*|\"(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21\\x23-\\x5b\\x5d-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])*\")@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?|\\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:(?:[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f\\x21-\\x5a\\x53-\\x7f]|\\\\[\\x01-\\x09\\x0b\\x0c\\x0e-\\x7f])+)\\])";
final String string = "David Hills\n"
+ "Primeresllc@gmail.com\n"
+ " · Reply · 42w\n"
+ "Adrian Chu\n"
+ "badge icon\n"
+ "adrian@adrianchu.net\n"
+ " · Reply · 42w\n"
+ "Nick Bagoshvili\n"
+ "badge icon\n"
+ "Nick@ngbroofing.com\n"
+ " · Reply · 42w\n"
+ "Grace Wang\n"
+ "grace@ClarityPropertiesLLC.com\n"
+ " · Reply · 42w\n"
+ "Pete Venturo\n"
+ "That's my neighbor.\n"
+ " · Reply · 42w\n"
+ "Hom Teang\n"
+ "mrteang@gmail.com\n"
+ " · Reply · 42w\n"
+ "Derek Stephens\n"
+ "derek@summitreiholdings.com\n"
+ " · Reply · 42w\n"
+ "Julie K Clark\n"
+ "Julie@seattleinvestorsclub.com\n"
+ " · Reply · 42w\n"
+ "Alex Frankov\n"
+ "alexfrankov@hotmail.com\n"
+ " · Reply · 42w\n"
+ "Dawn Armstrong\n"
+ "Dawnarmstrong&hotmail.com\n"
+ "Outlook – free personal email and calendar from Microsoft\n"
+ "OUTLOOK.LIVE.COM\n"
+ "Outlook – free personal email and calendar from Microsoft\n"
+ "Outlook – free personal email and calendar from Microsoft\n"
+ " · Reply · 42w\n"
+ "Andrey Gulyy\n"
+ "Andreygulyyre@gmail.com please\n"
+ " · Reply · 42w\n"
+ "Viktor Bondarenko\n"
+ "viktor76@outlook.com\n"
+ " · Reply · 42w\n"
+ "Jeremy Macconnell\n"
+ "Sendmeyourdeals@foursqre.com\n"
+ " · Reply · 42w\n"
+ "A Suraphong Liengboonlertchai\n"
+ "Abuysellproperty@gmail.com. Thx 🙏\n"
+ " · Reply · 42w\n"
+ "Kellen Giroux\n"
+ "info@upraisedproperties.com\n"
+ " · Reply · 42w\n"
+ "Anthony Markiie Prado\n"
+ "Amprado@kw.com\n"
+ " · Reply · 42w\n"
+ "Jamil Newman\n"
+ "Westshoreinvestmentgroup@gmail.com\n"
+ " · Reply · 42w\n"
+ "Joe Clark\n"
+ "Josephclark10@gmail.com\n"
+ " · Reply · 42w\n"
+ "Nick Taitano\n"
+ "It's a great opportunity!\n"
+ " · Reply · 41w\n"
+ "Miao Jiang\n"
+ "mj@everestinvestments.net\n"
+ " · Reply · 41w\n"
+ "AJ Sheffield\n"
+ "aj@theoffmarketdeals.com\n"
+ " · Reply · 41w\n"
+ "Cindy Highsmith\n"
+ "Flyfreelw@gmail.com\n"
+ " · Reply · 41w\n"
+ "Steven Wang\n"
+ "stevenwproperties@gmail.com\n"
+ " · Reply · 41w\n"
+ "Miao Jiang\n"
+ "mj@everestinvestments.net\n"
+ " · Reply · 40w\n"
+ "Les Dreeson\n"
+ "ldreeson@listings.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}