package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?<value>\d+)\s?(?<unit>m²|m\^2|cm²|cm\^2|ft|in|m|mm)\s?)+$`)
var str = `1ft1in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}