$re = '/(\/\/[^\n]*$|\/(?!\\\\)\*[\s\S]*?\*(?!\\\\)\/)/m';
$str = '/* Test
blabla
*/
// das ist ein
// kommentar test
/** javadoc
* bla blabla
* blablabla
*/
/*
blabla
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);