import Foundation
let pattern = #"(^Project\("{[a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12}}"\)\s*=\s*"[\w\d-.]*"\s*,\s*")\K([\w\d-.\\\s]*)(?=".*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
Microsoft Visual Studio Solution File, Format Version 12.00
# Visual Studio 14
VisualStudioVersion = 14.0.25420.1
MinimumVisualStudioVersion = 10.0.40219.1
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "CCH.WFM.UnitTest.Framework", "Source\Common\Tests\Unit Tests\WFMTestFramework\CCH.WFM.UnitTest.Framework.csproj", "{044E36A5-189E-45B1-9753-397BC8ACD31A}"
EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "CCH.WFM.ServiceTest", "Source\Common\Tests\Unit Tests\ServiceTest\CCH.WFM.ServiceTest.csproj", "{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}"
EndProject
Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "TestFramework", "..\test\TestFramework\TestFramework.csproj", "{3F56B03C-0883-4705-91BA-0979CAF6E719}"
EndProject
Global
GlobalSection(SolutionConfigurationPlatforms) = preSolution
Debug|Any CPU = Debug|Any CPU
Release|Any CPU = Release|Any CPU
EndGlobalSection
GlobalSection(ProjectConfigurationPlatforms) = postSolution
{044E36A5-189E-45B1-9753-397BC8ACD31A}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
{044E36A5-189E-45B1-9753-397BC8ACD31A}.Debug|Any CPU.Build.0 = Debug|Any CPU
{044E36A5-189E-45B1-9753-397BC8ACD31A}.Release|Any CPU.ActiveCfg = Release|Any CPU
{044E36A5-189E-45B1-9753-397BC8ACD31A}.Release|Any CPU.Build.0 = Release|Any CPU
{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Debug|Any CPU.Build.0 = Debug|Any CPU
{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Release|Any CPU.ActiveCfg = Release|Any CPU
{94E3C16B-DFBA-403A-95F9-37FAB7AB88ED}.Release|Any CPU.Build.0 = Release|Any CPU
{3F56B03C-0883-4705-91BA-0979CAF6E719}.Debug|Any CPU.ActiveCfg = Debug|Any CPU
{3F56B03C-0883-4705-91BA-0979CAF6E719}.Debug|Any CPU.Build.0 = Debug|Any CPU
{3F56B03C-0883-4705-91BA-0979CAF6E719}.Release|Any CPU.ActiveCfg = Release|Any CPU
{3F56B03C-0883-4705-91BA-0979CAF6E719}.Release|Any CPU.Build.0 = Release|Any CPU
EndGlobalSection
GlobalSection(SolutionProperties) = preSolution
HideSolutionNode = FALSE
EndGlobalSection
GlobalSection(TeamFoundationVersionControl) = preSolution
SccNumberOfProjects = 4
SccEnterpriseProvider = {4CA58AB2-18FA-4F8D-95D4-32DDF27D184C}
SccTeamFoundationServer = https://tfs2013.prosystemfx.com/tfs/nextgen
SccLocalPath0 = .
SccProjectUniqueName1 = Source\\Common\\Tests\\Unit\u0020Tests\\WFMTestFramework\\CCH.WFM.UnitTest.Framework.csproj
SccProjectName1 = Source/Common/Tests/Unit\u0020Tests/WFMTestFramework
SccLocalPath1 = Source\\Common\\Tests\\Unit\u0020Tests\\WFMTestFramework
SccProjectUniqueName2 = Source\\Common\\Tests\\Unit\u0020Tests\\ServiceTest\\CCH.WFM.ServiceTest.csproj
SccProjectName2 = Source/Common/Tests/Unit\u0020Tests/ServiceTest
SccLocalPath2 = Source\\Common\\Tests\\Unit\u0020Tests\\ServiceTest
SccProjectUniqueName3 = ..\\test\\TestFramework\\TestFramework.csproj
SccProjectName3 = ../test/TestFramework
SccLocalPath3 = ..\\test\\TestFramework
EndGlobalSection
EndGlobal
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)