$re = '/(select\s+|([^,]+as)|from.+)/mi';
$str = 'SELECT id, id_alarm, ne_name, extract(epoch from create_alarm_dt) as create_alarm_dt, extract(epoch from create_date) as create_date, extract(epoch from modify_date) as modify_date, create_user, modify_user, description FROM ecus.prog_ack_comments WHERE create_user=\'avpozov\'
id,id_alarm, ne_name, extract(epoch from create_alarm_dt) as create_alarm_dt, extract(epoch from create_date) as create_date, extract(epoch from modify_date) as modify_date, create_user, modify_user, description';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;