using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""category-gallery-item"">\n(?:.*)<a href=""\/wiki\/[^""]*"" title=""[^""]*"">\n(?:.*)<div class=""category-gallery-item-image"">\n(?:.*)https:\/\/images\.wikia\.nocookie\.net\/(?:.*)\/americanhorrorstory\/images\/thumb\/(?P<filepath>[^\/]\/[^\/]{2}\/[^\/]*)\/(?:.*)\n(?:.*)\n(?:.*)<div class=""title"">(?P<title>[^\n]*)<\/div>\n\s*<\/a>\n\s*<\/div>";
string substitution = @"${title} https://vignette.wikia.nocookie.net/americanhorrorstory/images/${filepath}/revision/latest/";
string input = @"<div class=""category-gallery-room1"">
<div class=""category-gallery-item"">
<a href=""/wiki/Tate_Langdon"" title=""Tate Langdon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170918121337/americanhorrorstory/images/thumb/6/6a/MurderHouse3.jpg/130px-0%2C1879%2C30%2C1692-MurderHouse3.jpg"" alt=""Tate Langdon"" width=""130"" height=""115"">
</div>
<div class=""title"">Tate Langdon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Constance_Langdon"" title=""Constance Langdon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170901150853/americanhorrorstory/images/thumb/0/01/Scnet_ahs_promos01_019.jpg/130px-0%2C1881%2C32%2C1696-Scnet_ahs_promos01_019.jpg"" alt=""Constance Langdon"" width=""130"" height=""115"">
</div>
<div class=""title"">Constance Langdon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Infantata"" title=""Infantata"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20140211011227/americanhorrorstory/images/thumb/8/8a/Infantata-benjamin-woolf-american-horror-story-3.png/130px-139%2C616%2C0%2C421-Infantata-benjamin-woolf-american-horror-story-3.png"" alt=""Infantata"" width=""130"" height=""115"">
</div>
<div class=""title"">Infantata</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Moira_O%27Hara"" title=""Moira O'Hara"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20161118211513/americanhorrorstory/images/thumb/1/11/Moira_double.jpg/130px-0%2C250%2C5%2C226-Moira_double.jpg"" alt=""Moira O'Hara"" width=""130"" height=""115"">
</div>
<div class=""title"">Moira O'Hara</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Vivien_Harmon"" title=""Vivien Harmon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170901162145/americanhorrorstory/images/thumb/9/92/02e87f12aa77ee5561190934d0563538.jpg/130px-0%2C2033%2C35%2C1833-02e87f12aa77ee5561190934d0563538.jpg"" alt=""Vivien Harmon"" width=""130"" height=""115"">
</div>
<div class=""title"">Vivien Harmon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Billie_Dean_Howard"" title=""Billie Dean Howard"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20161016014729/americanhorrorstory/images/thumb/d/d8/Billie_Dean_Howard_-_Hotel.jpg/130px-75%2C528%2C0%2C400-Billie_Dean_Howard_-_Hotel.jpg"" alt=""Billie Dean Howard"" width=""130"" height=""115"">
</div>
<div class=""title"">Billie Dean Howard</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Violet_Harmon"" title=""Violet Harmon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170831083449/americanhorrorstory/images/thumb/d/d4/Taissa-farmiga-as-violet-harmon-in-american-horror-story-1.jpg/130px-0%2C390%2C6%2C351-Taissa-farmiga-as-violet-harmon-in-american-horror-story-1.jpg"" alt=""Violet Harmon"" width=""130"" height=""115"">
</div>
<div class=""title"">Violet Harmon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Hayden_McClaine"" title=""Hayden McClaine"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121211204512/americanhorrorstory/images/thumb/9/97/Download_%288%29.jpg/130px-156%2C700%2C0%2C480-Download_%288%29.jpg"" alt=""Hayden McClaine"" width=""130"" height=""115"">
</div>
<div class=""title"">Hayden McClaine</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Ben_Harmon"" title=""Ben Harmon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170901161948/americanhorrorstory/images/thumb/4/45/Scnet_ahs_promos01_001.jpg/130px-0%2C1573%2C28%2C1420-Scnet_ahs_promos01_001.jpg"" alt=""Ben Harmon"" width=""130"" height=""115"">
</div>
<div class=""title"">Ben Harmon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Beauregard_Langdon"" title=""Beauregard Langdon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121029040849/americanhorrorstory/images/thumb/7/78/Beau2.png/130px-161%2C916%2C0%2C667-Beau2.png"" alt=""Beauregard Langdon"" width=""130"" height=""115"">
</div>
<div class=""title"">Beauregard Langdon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Adelaide_Langdon"" title=""Adelaide Langdon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170901143540/americanhorrorstory/images/thumb/1/10/Scnet_ahs_promos01_025.jpg/130px-0%2C1805%2C29%2C1626-Scnet_ahs_promos01_025.jpg"" alt=""Adelaide Langdon"" width=""130"" height=""115"">
</div>
<div class=""title"">Adelaide Langdon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Larry_Harvey"" title=""Larry Harvey"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20170831083606/americanhorrorstory/images/thumb/d/d0/American-horror-story-denis-ohare-4.jpg/130px-0%2C540%2C9%2C487-American-horror-story-denis-ohare-4.jpg"" alt=""Larry Harvey"" width=""130"" height=""115"">
</div>
<div class=""title"">Larry Harvey</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Nora_Montgomery"" title=""Nora Montgomery"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20140212014448/americanhorrorstory/images/thumb/9/9f/Tumblr_mm7qwzHIgM1rjrfw0o1_500.png/130px-94%2C410%2C0%2C279-Tumblr_mm7qwzHIgM1rjrfw0o1_500.png"" alt=""Nora Montgomery"" width=""130"" height=""115"">
</div>
<div class=""title"">Nora Montgomery</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Charles_Montgomery"" title=""Charles Montgomery"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20171012044313/americanhorrorstory/images/thumb/1/1a/Montgomery.jpg/130px-0%2C503%2C9%2C454-Montgomery.jpg"" alt=""Charles Montgomery"" width=""130"" height=""115"">
</div>
<div class=""title"">Charles Montgomery</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Hugo_Langdon"" title=""Hugo Langdon"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121028001711/americanhorrorstory/images/thumb/0/02/Hugo.png/130px-0%2C663%2C10%2C597-Hugo.png"" alt=""Hugo Langdon"" width=""130"" height=""115"">
</div>
<div class=""title"">Hugo Langdon</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Travis_Wanderly"" title=""Travis Wanderly"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20111222045635/americanhorrorstory/images/thumb/e/ee/AmericanHorrorStory-travis.jpg/130px-0%2C287%2C4%2C258-AmericanHorrorStory-travis.jpg"" alt=""Travis Wanderly"" width=""130"" height=""115"">
</div>
<div class=""title"">Travis Wanderly</div>
</a>
</div>
</div>
<div class=""category-gallery-room1"" style=""margin-left: 0px;""><div class=""category-gallery-item"">
<a href=""/wiki/Rubber_Man"" title=""Rubber Man"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20111216004411/americanhorrorstory/images/thumb/6/61/Ahs1120005_595.jpg/130px-0%2C396%2C8%2C358-Ahs1120005_595.jpg"" alt=""Rubber Man"" width=""130"" height=""115"">
</div>
<div class=""title"">Rubber Man</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Elizabeth_Short"" title=""Elizabeth Short"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121024055325/americanhorrorstory/images/thumb/d/d6/Dahlia2.png/130px-0%2C569%2C10%2C513-Dahlia2.png"" alt=""Elizabeth Short"" width=""130"" height=""115"">
</div>
<div class=""title"">Elizabeth Short</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Chad_Warwick"" title=""Chad Warwick"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20111105101300/americanhorrorstory/images/thumb/c/cf/Chad.jpg/130px-0%2C719%2C9%2C645-Chad.jpg"" alt=""Chad Warwick"" width=""130"" height=""115"">
</div>
<div class=""title"">Chad Warwick</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Marcy"" title=""Marcy"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20151004153134/americanhorrorstory/images/thumb/8/83/Marcy.jpg/130px-180%2C832%2C0%2C576-Marcy.jpg"" alt=""Marcy"" width=""130"" height=""115"">
</div>
<div class=""title"">Marcy</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Troy_and_Bryan"" title=""Troy and Bryan"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121104143121/americanhorrorstory/images/thumb/6/61/Images_%2835%29.jpg/130px-234%2C1049%2C0%2C720-Images_%2835%29.jpg"" alt=""Troy and Bryan"" width=""130"" height=""115"">
</div>
<div class=""title"">Troy and Bryan</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Hallie"" title=""Hallie"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121115111401/americanhorrorstory/images/thumb/b/b5/Hallie.jpg/130px-0%2C378%2C7%2C341-Hallie.jpg"" alt=""Hallie"" width=""130"" height=""115"">
</div>
<div class=""title"">Hallie</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Patrick"" title=""Patrick"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20111105101725/americanhorrorstory/images/thumb/4/40/Pat_2.jpg/130px-0%2C523%2C9%2C472-Pat_2.jpg"" alt=""Patrick"" width=""130"" height=""115"">
</div>
<div class=""title"">Patrick</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Leah"" title=""Leah"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20111023041839/americanhorrorstory/images/thumb/c/cd/Leah.jpg/130px-148%2C663%2C0%2C455-Leah.jpg"" alt=""Leah"" width=""130"" height=""115"">
</div>
<div class=""title"">Leah</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Lorraine_Harvey"" title=""Lorraine Harvey"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20111117175740/americanhorrorstory/images/thumb/0/0d/Lorraineharveybio.jpg/130px-27%2C411%2C0%2C339-Lorraineharveybio.jpg"" alt=""Lorraine Harvey"" width=""130"" height=""115"">
</div>
<div class=""title"">Lorraine Harvey</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Luke_(Murder_House)"" title=""Luke (Murder House)"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121027065901/americanhorrorstory/images/thumb/4/4f/Luke.png/130px-0%2C524%2C9%2C473-Luke.png"" alt=""Luke (Murder House)"" width=""130"" height=""115"">
</div>
<div class=""title"">Luke (Murder House)</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/R._Franklin"" title=""R. Franklin"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121027184749/americanhorrorstory/images/thumb/3/37/Franklin.png/130px-0%2C374%2C9%2C340-Franklin.png"" alt=""R. Franklin"" width=""130"" height=""115"">
</div>
<div class=""title"">R. Franklin</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Jack_Colquitt"" title=""Jack Colquitt"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20121028070935/americanhorrorstory/images/thumb/4/46/Jack.png/130px-250%2C1119%2C0%2C768-Jack.png"" alt=""Jack Colquitt"" width=""130"" height=""115"">
</div>
<div class=""title"">Jack Colquitt</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Dr._Hall"" title=""Dr. Hall"">
<div class=""category-gallery-item-image"">
<img src=""https://images.wikia.nocookie.net/__cb20130122041507/americanhorrorstory/images/thumb/b/b4/Hall.png/130px-0%2C691%2C9%2C620-Hall.png"" alt=""Dr. Hall"" width=""130"" height=""115"">
</div>
<div class=""title"">Dr. Hall</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Amir_Stanley"" title=""Amir Stanley"">
<div class=""category-gallery-item-image"">
<div class=""snippet"">
<span class=""quote"">“</span>
<span class=""text"">REDIRECT Westfield High/Massacre#Amir Stanley This is a redirect from a character link. In other...</span>
</div>
</div>
<div class=""title"">Amir Stanley</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Angela_Harvey"" title=""Angela Harvey"">
<div class=""category-gallery-item-image"">
<div class=""snippet"">
<span class=""quote"">“</span>
<span class=""text"">REDIRECT Lorraine Harvey#Angela Harvey This is a redirect from a character link. In other words...</span>
</div>
</div>
<div class=""title"">Angela Harvey</div>
</a>
</div>
<div class=""category-gallery-item"">
<a href=""/wiki/Angie"" title=""Angie"">
<div class=""category-gallery-item-image"">
<div class=""snippet"">
<span class=""quote"">“</span>
<span class=""text"">REDIRECT Piggy Piggy#Angie This is a redirect from a character link. In other words, this is a...</span>
</div>
</div>
<div class=""title"">Angie</div>
</a>
</div>
</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}