$re = '/^([a-b]).*\1$|^[a-b]{1}$/m';
$str = 'a
b
aaabb
abba
baab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);