using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.*?;){6}(?'champs1'.*?);""(?'champs2'.*?)"";(?:.*?;){6}""(?'champs5'.*?)"";(?:.*?;)""(?'champs4'.*?)"";""(?'champs3'.*?)"";";
string input = @"""I01.00.00"";""005291"";""CG45"";""15085"";""cnt_ext"";""1905151405"";181349;""CE_11"";""DYER Isabelle"";""02 38 25 40 72"";003;""Non"";""site_ext"";""COLLEGE VAL DE LOIRE"";""SIT_036"";""COLLEGE VAL DE LOIRE"";""[Dem : 1905151405] DYSFONCTIONNEMENT PORTE EXTERIEURE PRES DE LA SALLE"";""28/05/2019 00:00"";""CASTELLI Olivier"";""02 38 49 20 00"";"";""olivier.castelli1@ac-orleans-tours.fr"";""28/05/2019 00:00"";0;""r�soudre le dysfonctionnement de la porte ext�rieure � proximit� de la salle polyvalente. K151405""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}