re = /\((?<Classification>[U|S])\)(?<Content>[^\(*)]*)/m
str = '(U) foo bar
some more text
(S) yep here too'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end