# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\d]?(?:(\d\d)[^\d]?(\d\d)[^\d]?(\d\d)(\.[\d\w]{1,}){0,1})(.*)$"
test_str = ("123456.123abc\n"
"00 24 13.13456789 Scopes of Bids (Multiple Contracts) \n"
"00 24 13.16 Scopes of Bids (Multiple-Prime Contract) \n"
"00 00 00 Procurement and Contracting Requirements \n"
"00 01 01 Project Title Page \n"
"00 01 05 Certifications Page \n"
"00 01 07 Seals Page \n"
"00 01 10 Table of Contents \n"
"00 01 15 List of Drawing Sheets \n"
"00 01 20 List of Schedules \n"
"00 10 00 Solicitation \n"
"00 11 00 Advertisements and Invitations \n"
"00 11 13 Advertisement for Bids \n"
"00 11 16 Invitation to Bid \n"
"00 11 19 Request for Proposal \n"
"00 11 53 Request for Qualifications \n"
"00 20 00 Instructions for Procurement \n"
"00 21 00 Instructions \n"
"00 21 13 Instructions to Bidders \n"
"00 21 16 Instructions to Proposers \n"
"00 22 00 Supplementary Instructions \n"
"00 22 13 Supplementary Instructions to Bidders \n"
"00 22 16 Supplementary Instructions to Proposers \n"
"00 23 00 Procurement Definitions \n"
"00 24 00 Procurement Scopes \n"
"00 24 13 Scopes of Bids ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.