$re = '/^[0]{1}[0-9]{9,10}$/';
$str = '0123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);