re = /^\s*(\w+)\s*$|(?:\[\s*(\w+)\s*(?:,\s*(\w+)\s*)*\])/
str = 'rollingmedian( ecoli, orgs/100mL, [tat10, tat11] ) + latest(ecoli,) + diffdays(ecoli)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end