re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!@#\$%\^&\*])(?=.{8,})/m
str = 'Teest1234$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end