package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[@]{1}[aA][l]{2}|[ ][@]{1}[aA][l]{2}?[ ]{1}+$`)
var str = `@all `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}