const regex = /(?:<[^>]*>)?(accessed(?:\s*\:?\s*| on ))((?:[0-2]?[0-9]?|30|31)(?:st|nd|rd|th)?)(?:<\/[^>]*>)?([\.\-\/ ])(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?|[1-9]|1[012])([\.\-\/ ])(?:<[^>]*>)?(20\d{2})(?:<\/[^>]*>)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<[^>]*>)?(accessed(?:\\s*\\:?\\s*| on ))((?:[0-2]?[0-9]?|30|31)(?:st|nd|rd|th)?)(?:<\\\/[^>]*>)?([\\.\\-\\\/ ])(Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|June?|July?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?|[1-9]|1[012])([\\.\\-\\\/ ])(?:<[^>]*>)?(20\\d{2})(?:<\\\/[^>]*>)?', 'gm')
const str = `<note>accessed 13</note> March <year>2022</year>
<note>accessed 13th</note> March <year>2022</year>
<note>accessed 8</note> April <year>2022</year>.
accessed 21st February 2020
accessed 32 Febr 2022
accessed 32 February 2022
accessed 30 February 202
accessed 30 January 2022
accessed 30 Jan 2022
accessed 30 February 2022
accessed 30 Feb 2022
accessed: 30 March 2022
accessed on 30 Mar 2022
accessed 30 April 2022
accessed 30 Apr 2022
accessed 30 May 2022
accessed 30 June 2022
accessed 30 Jun 2022
accessed 30 July 2022
accessed 30 Jul 2022
accessed 30 August 2022
accessed 30 Aug 2022
accessed 30 September 2022
accessed 30 Sep 2022
accessed 30 October 2022
accessed 30 Oct 2022
accessed 30 November 2022
accessed 30 Nov 2022
accessed 30 December 2022
accessed 30 Dec 2022
accessed on 30.12.2022
accessed on 30.13.2022
accessed on 34.12.2022
accessed on 30.12.2023
accessed on 30.15.2022
accessed on 01.12.2022
accessed on 41.12.2092
accessed on 30-12-2022
accessed on 30-13-2022
accessed on 34-12-2022
accessed :30-12-2023
accessed :30-15-2022
accessed :01-12-2022
accessed :41-12-2092
accessed : 30/12/2022
accessed : 30/13/2022
accessed :34/12/2022
accessed :30/12/2023
accessed : 30/15/2022
accessed 01/12/2022
accessed 41/12/2092
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}