# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!cpc|accounts\.)(google|bing|search\.yahoo|search\.myway|yandex|duckduckgo|ecosia|search\.tb\.ask|baidu)(?!.*cpc)"
test_str = ("google/cpc/[google][cpc][house][sale]\n"
"google/cpc/[google][cpc][condo][sale]\n"
"accounts.google.com.sg\n"
"accounts.google.co.id\n"
"google.com\n"
"google.com.ph\n"
"google.co.th\n"
"bing.com\n"
"google.co.uk\n"
"com.google.android.googlequicksearchbox\n"
"google.com.sg\n"
"google.com.au\n"
"google.com.vn\n"
"google.ca\n"
"google.co.id\n"
"google.com.hk\n"
"search.yahoo.com\n"
"duckduckgo.com\n"
"google.de\n"
"ph.search.yahoo.com\n"
"google.co.in\n"
"google.fr\n"
"google.co.jp\n"
"google.co.kr\n"
"google.com.my\n"
"google.ae\n"
"google.se\n"
"google.ch\n"
"int.search.myway.com\n"
"yandex.ru\n"
"google.ru\n"
"google.com.tw\n"
"google.nl\n"
"cn.bing.com\n"
"ecosia.org\n"
"google.it\n"
"google.dk\n"
"google.co.nz\n"
"int.search.tb.ask.com\n"
"search.yahoo.co.jp\n"
"google.co.za\n"
"google.no\n"
"google.es\n"
"google.be\n"
"th.search.yahoo.com\n"
"google.fi\n"
"baidu.com\n"
"google.ie\n"
"google.com.tr\n"
"uk.search.yahoo.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.