import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]+) ?([1-9]+)[, ]*[0-9]\\{,2\\}:[0-9]\\{,2\\}[^,]+, ?T=([-0-9]+)degr?";
final String string = "# Measurements started\n"
+ "Sep 9, 9:05, T=22deg\n"
+ "SEP 9, 10:15, T=25deg\n"
+ "# Taking a coffee break\n"
+ "Sep 9, 11:15, T=-10deg\n"
+ "# Weekend\n"
+ "Sept 12, 09:00AM, T=32deg\n"
+ "Oct12 13:00, T=32degr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}