import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^.*\\.(.*\\.[a-z]{0,3})|(?i)([a-z]{0,3}\\..*\\.[a-z]{0,3}|.*\\.[a-z]{0,3})$$";
final String string = "ch.iqos.com\n"
+ "discoveriqos.com\n"
+ "faramentol.ro\n"
+ "foodhouse.md\n"
+ "futurosinhumo.com\n"
+ "ganaconpmi.com\n"
+ "getinfo.kr\n"
+ "heatnotburn.se\n"
+ "iqommunity.ro\n"
+ "iqosclub.cz\n"
+ "iqosclub.sk\n"
+ "iqosclubcanarias.com\n"
+ "iqosempfehlen.at\n"
+ "iqositalia.it\n"
+ "iqosphere.jp\n"
+ "iqossvc.kr\n"
+ "iqosveda.cz\n"
+ "iqosveda.sk\n"
+ "newcreations.kr\n"
+ "prohibicionmentolado2020.es\n"
+ "proibicao-mentol2020.pt\n"
+ "qreator.ro\n"
+ "referiqosmy.com\n"
+ "shareiqos.ch\n"
+ "timeforchanges.ch\n"
+ "tryiqos.kr\n"
+ "unsmoke.de\n"
+ "iqostravel.com\n"
+ "iqostage.jp\n"
+ "iqos-register.jp\n"
+ "mystartapp.org\n"
+ "iqosclub.ch\n"
+ "dimensions.kz\n"
+ "www.tryiqos.ru\n"
+ "www.timeforchanges.ch\n"
+ "www.testiqos.ch\n"
+ "readmodel.m.sogou.com\n"
+ "www.shareiqos.ch";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}