# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ *[^\s]+( +[^\s]+)*$"
test_str = ("# UFIS : User-Friendly and Instant Installer System\n\n"
"# Each comment starts with '#' and ends with a new line.\n"
"# Each statement is written in one line.\n"
"# Commands' and built-in variables' names are always uppercase.\n"
"# A custom variable name must have at least one lowercase character and must begin with a letter or the underscore (_).\n\n"
"LET APP_NAME = \"MyApp\"\n"
"LET APP_VERSION = \"1.0.0\"\n\n"
"LET a = MATERIAL \"folderx/\"\n"
"a -= \"test.exe\"\n"
"a -= \"main.exe\"\n"
"a += MATERIAL \"folderz/\"\n"
"a += MATERIAL \"README.md\"\n\n"
"LET b = MATERIAL \"folderx/test.exe\"\n\n"
"LET c = MATERIAL \"folderx/main.exe\"\n\n"
"IF INSTALLING\n"
" LET iAcceptLicense = INPUT CHECKBOX \"Accept [license](https://myapp.com/license)\" MANDATORY\n"
" IF iAcceptLicense == FALSE\n"
" QUIT\n"
" ENDIF\n\n"
" LET iLanguage = INPUT CHOICES \"Vietnamese\" OR \"English\" DEFAULT \"English\" MANDATORY\n\n"
" LET INSTALL_DIR = INPUT DIRECTORY \"Installation directory\" POSTFIX \"/${APP_NAME}\" DEFAULT PROGRAM_FILES\n"
" LET iInstallTest = INPUT CHECKBOX \"Install test.exe\" DEFAULT FALSE\n"
" LET iCreateDesktopShortcut = INPUT CHECKBOX \"Create desktop shortcut\" DEFAULT TRUE\n"
" LET iLaunchAtStartup = INPUT CHECKBOX \"Launch program at startup\" DEFAULT TRUE\n\n"
" INSTALL a AND c TO INSTALL_DIR # the same as \"${INSTALL_DIR}\"\n\n"
" IF iInstallTest == TRUE\n"
" INSTALL b TO INSTALL_DIR AS \"test_program.exe\"\n"
" ENDIF\n\n"
" IF iCreateDesktopShortcut == TRUE\n"
" CREATE SHORTCUT FOR c IN DESKTOP_ALL_USERS\n"
" ENDIF\n\n"
" IF iLaunchAtStartup == TRUE\n"
" RUN c AT STARTUP\n"
" ENDIF\n"
" \n"
" WORK registry_work\n"
" CREATE REGSZ \"HKEY_LOCAL_MACHINE/Software/${APP_NAME}\" VALUE \"1\"\n"
" ENDWORK\n"
" \n"
" CPP\n"
" #include <iostream>\n"
" \n"
" void entry() {\n"
" std::cout << \"Not very intelligent\";\n"
" }\n"
" ENDCPP\n"
" \n"
" CALL entry\n\n"
"ELIF RUNNING\n"
" RUN c\n\n"
"ELSE # UNINSTALLING\n"
" UNDO ALL EXCEPT registry_work\n\n"
"ENDIF\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.