const regex = /^(\w+(\.|-)*\w+)+@(\w+-?\w+)+\.[a-z]{2,3}(\.[a-z]{2})?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+(\\.|-)*\\w+)+@(\\w+-?\\w+)+\\.[a-z]{2,3}(\\.[a-z]{2})?', 'mg')
const str = `abir.hasan.123@abir-hasan-limon.edu.bd
abir.spsc@gmail.com
sushipoo777@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}