#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(\D{2})(\d{10})(.*)"
Local $sString = "0320818717nullnullnullnullnullnullnullnullnullnullnullnullnullnullPubDSK_1nullnullnullnullnullnullnullnull341280nullnull1016041506FOREROnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullAYALAnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullDIEGOnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullnullALEJANDROnullnullnullnullnullnullnullnullnullnullnullnullnullnull0M19920113150010O+null2[STX]CnullZ ÇÇ{jÅYP¡B$MâDz<¼ßh[DLE]Fѱa[DC4]íBnjéMéoÜ]ê$£uàºúgòVîYòZdæsÖnull¢«¡GïakªúUñ,~á`¡Üaô]jf$Hüÿ[FF]Q|Ñ[DC4]ª[DC4]de忱¬,nullÿRáç[»Xkb¢9ºÀ¥`ldpjLvR}WÆUkvmez[çZ÷´«i}[ù*ë[DC4]AB M$ null7[STX]Cnull[DLE]Y ÇÇ\zoÆwígÿïª`Öm[STX]æ¿XÄ$JüFÉAâEs«K\V§Kc¢düöUÑ5c-<:«ùåLöB£7Ñ#JlïG[ESC]á2ÿ[FS]æmò2èiî@?Xï)É9ld[4àüüGéDcRc¿]GdoV5[DLE]2,Jï`T;ägom}sçuO<Zln5ïsCgRpêtG_Vö1mcäBh[DC2]M ìRWöè²null[SUB][ESC]?[SUB]¦a<Të[SOH]ª[DC2]eë^0aïM[DLE]c[CR][DLE][j [SO]nullXOy`h_xgú[SYN][CR]"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)