re = /(?<=^|]).*?(?=\[|$)/m
str = 'fdsafsda[fsdfsd]fsdfsdfds[fsdfsdfsd]fsdffsdf[sdfsdfsdfsd]fsdfsdfsd
fdsafsda[fsdfsd]fsdfsdfds[fsdfsdfsd]fsdffsdf[sdfsdfsdfsd]fsdfsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end