import Foundation
let pattern = #"Start\W+([0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'\ufeffStore :,RS1 FAC_RS1 (South) ,Cashier :,2079 : Holly,Terminal :,2 : POS2 ,Receipt Number :,59450,Invoice Number :,RS102059450,Start :,01/01/2016 06:35:23 AM,End : ,01/01/2016 06:35:23 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,',
'Store :,RS1 FAC_RS1 (South) ,Cashier :,2138 : Mark,Terminal :,4 : POS4 ,Receipt Number :,59234,Invoice Number :,RS104059234,Start :,01/01/2016 06:41:41 AM,End : ,01/01/2016 06:41:41 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,',
'Store :,RS1 FAC_RS1 (South) ,Cashier :,2138 : Mark,Terminal :,3 : POS3 ,Receipt Number :,64407,Invoice Number :,RS103064407,Start :,01/01/2016 06:43:54 AM,End : ,01/01/2016 06:43:54 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,',
'Store :,RS1 FAC_RS1 (South) ,Cashier :,2138 : Mark,Terminal :,5 : POS5 ,Receipt Number :,64806,Invoice Number :,RS105064806,Start :,01/01/2016 06:46:21 AM,End : ,01/01/2016 06:46:21 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,',
'Store :,RS1 FAC_RS1 (South) ,Cashier :,1618 : Aron,Terminal :,6 : POS6 ,Receipt Number :,67963,Invoice Number :,RS106067963,Start :,01/01/2016 06:56:34 AM,End : ,01/01/2016 06:56:34 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,',
'Store :,RS1 FAC_RS1 (South) ,Cashier :,1618 : Aron,Terminal :,6 : POS6 ,Receipt Number :,67964,Invoice Number :,RS106067964,Start :,01/01/2016 07:20:35 AM,End : ,01/01/2016 07:21:04 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,\n668,FA BRKFST WRAP,2.000,$2.99,$5.98,,,,,,,,,\n102,COFFEE 12 OZ,1.000,$1.50,$1.50,,,,,,,,,',
'Store :,RS1 FAC_RS1 (South) ,Cashier :,1618 : Aron,Terminal :,6 : POS6 ,Receipt Number :,67964,Invoice Number :,RS106067964,Start :,01/01/2016 07:20:35 AM,End : ,01/01/2016 07:21:04 AM\nItem ID,Receipt Alias,Quantity Sold,Unit Price,Extended Price,,,,,,,,,\n,SUBTOTAL,,,$7.48,,,,,,,,,\n,TOTAL,,,$7.48,,,,,,,,,\n,TOTAL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)