use strict;
my $str = '# Example functions using print that we want to extract the substitution args from
def Initialise(self):
print \'# NDOverlayConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, NOverlays, maxBuffers, maxMemory, priority, stackSize, maxThreads)\'
print \'NDOverlayConfigure("%(PORT)s", %(QUEUE)d, %(BLOCK)d, "%(NDARRAY_PORT)s", %(NDARRAY_ADDR)s, %(NOverlays)d, 0, 0, 0, 0, %(MAX_THREADS)d)\' % self.__dict__
def Initialise(self):
print(\'# NDROIStatConfigure(portName, queueSize, blockingCallbacks, \'
\'NDArrayPort, NDArrayAddr, maxROIs, maxBuffers, maxMemory,\'
\'priority\', \'stackSize\', \'maxThreads\')
print(\'NDROIStatConfigure("{PORT}", {QUEUE}, {BLOCK}, \'
\'"{NDARRAY_PORT}", {NDARRAY_ADDR}, {MAX_ROIS}, \'
\'0, 0, 0, 0, {MAX_THREADS})\'.format(**self.__dict__))
def Initialise(self):
print \'# NDStdArraysConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, maxBuffers, maxMemory, priority, stackSize, maxThreads)\'
print \'NDStdArraysConfigure("%(PORT)s", %(QUEUE)d, %(BLOCK)d, "%(NDARRAY_PORT)s", %(NDARRAY_ADDR)s, 0, 0, 0, 0, %(MAX_THREADS)d)\' % self.__dict__
';
my $regex = qr/(?:(?<=%\()|(?<={))([^\){]*)(?=[}\)])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}