const regex = new RegExp('^(?:\\d{4}-\\d{4}-\\d{2}|\\d{5}-(?:\\d{3}-\\d{2}|\\d{4}-\\d{1,2})|\\d{11}|\\d{10}|\\d{9})$', 'gm')
const str = `1234-1234-12
12345-123-12
12345-1234-1
12345-1234-12
12345678902
1234567890
123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}