import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(1(\\s|-)?)?(\\+\\d{1,3}\\s?)?((\\(\\d{3}\\)\\s?)|(\\d{3})(\\s|-?))(\\d{3}(\\s|-?))(\\d{4})(\\s?(([E|e]xt[:|.|]?)|x|X)(\\s?\\d+))?";
final String string = "/* Regular local phone number (XXX) XXX-XXXX */\n"
+ "1231231231\n"
+ "123-1231231\n"
+ "123123-1231\n"
+ "123-123 1231\n"
+ "123 123-1231\n"
+ "123-123-1231\n"
+ "(123)123-1231\n"
+ "(123)123 1231\n"
+ "(123) 123-1231\n"
+ "(123) 123 1231\n"
+ "1(212)2231141\n"
+ "1 232 442 1123\n"
+ "1-233-223-4433\n"
+ "12232234433\n"
+ "1(732) 1131131\n\n"
+ "/* International codes +XXX (XXX) XXX-XXXX */\n"
+ "+99 1234567890\n"
+ "+991234567890\n\n"
+ "/* Extensions (XXX) XXX-XXXX Ext. XXX... */\n"
+ "1234567890 Ext 1123123\n"
+ "1234567890Ext 1123123\n"
+ "1234567890 Ext1123123\n"
+ "1234567890Ext1123123\n\n"
+ "1234567890 Ext: 1123123\n"
+ "1234567890Ext: 1123123\n"
+ "1234567890 Ext:1123123\n"
+ "1234567890Ext:1123123\n\n"
+ "1234567890 Ext. 1123123\n"
+ "1234567890Ext. 1123123\n"
+ "1234567890 Ext.1123123\n"
+ "1234567890Ext.1123123\n\n"
+ "1234567890 ext 1123123\n"
+ "1234567890ext 1123123\n"
+ "1234567890 ext1123123\n"
+ "1234567890ext1123123\n\n"
+ "1234567890 ext: 1123123\n"
+ "1234567890ext: 1123123\n"
+ "1234567890 ext:1123123\n"
+ "1234567890ext:1123123\n\n"
+ "1234567890 X 1123123\n"
+ "1234567890X1123123\n"
+ "1234567890X 1123123\n"
+ "1234567890 X1123123\n"
+ "1234567890 x 1123123\n"
+ "1234567890x1123123\n"
+ "1234567890 x1123123\n"
+ "1234567890x 1123123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}