#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms),\s*("subresource_uris":.[^}]*[}])"
Local $sString = "{" & @CRLF & _
" "first_page_uri": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/LastMonth.json?PageSize=1000&Page=0"," & @CRLF & _
" "end": 387," & @CRLF & _
" "previous_page_uri": null," & @CRLF & _
" "uri": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/LastMonth.json?PageSize=1000&Page=0"," & @CRLF & _
" "page_size": 1000," & @CRLF & _
" "start": 0," & @CRLF & _
" "usage_records": [" & @CRLF & _
" {" & @CRLF & _
" "category": "wireless-usage"," & @CRLF & _
" "description": "SIM Usage"," & @CRLF & _
" "account_sid": "ACd7a7c24a3c7b0b0ddcde452fd6c18aae"," & @CRLF & _
" "start_date": "2023-01-01"," & @CRLF & _
" "end_date": "2023-01-31"," & @CRLF & _
" "as_of": "2023-02-05T06:53:40+00:00"," & @CRLF & _
" "count": "0"," & @CRLF & _
" "count_unit": "units"," & @CRLF & _
" "usage": "0"," & @CRLF & _
" "usage_unit": "units"," & @CRLF & _
" "price": "0"," & @CRLF & _
" "price_unit": "usd"," & @CRLF & _
" "api_version": "2010-04-01"," & @CRLF & _
" "uri": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/LastMonth.json?Category=wireless-usage&StartDate=2023-01-01&EndDate=2023-01-31"," & @CRLF & _
" "subresource_uris": {" & @CRLF & _
" "all_time": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/AllTime.json?Category=wireless-usage"," & @CRLF & _
" "today": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Today.json?Category=wireless-usage"," & @CRLF & _
" "yesterday": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Yesterday.json?Category=wireless-usage"," & @CRLF & _
" "this_month": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/ThisMonth.json?Category=wireless-usage"," & @CRLF & _
" "last_month": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/LastMonth.json?Category=wireless-usage"," & @CRLF & _
" "daily": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Daily.json?Category=wireless-usage"," & @CRLF & _
" "monthly": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Monthly.json?Category=wireless-usage"," & @CRLF & _
" "yearly": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Yearly.json?Category=wireless-usage"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "category": "pv-basic-rooms"," & @CRLF & _
" "description": "Go Rooms"," & @CRLF & _
" "account_sid": "ACd7a7c24a3c7b0b0ddcde452fd6c18aae"," & @CRLF & _
" "start_date": "2023-01-01"," & @CRLF & _
" "end_date": "2023-01-31"," & @CRLF & _
" "as_of": "2023-02-05T06:53:40+00:00"," & @CRLF & _
" "count": "0"," & @CRLF & _
" "count_unit": ""," & @CRLF & _
" "usage": "0"," & @CRLF & _
" "usage_unit": ""," & @CRLF & _
" "price": "0"," & @CRLF & _
" "price_unit": "usd"," & @CRLF & _
" "api_version": "2010-04-01"," & @CRLF & _
" "uri": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/LastMonth.json?Category=pv-basic-rooms&StartDate=2023-01-01&EndDate=2023-01-31"," & @CRLF & _
" "subresource_uris": {" & @CRLF & _
" "all_time": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/AllTime.json?Category=pv-basic-rooms"," & @CRLF & _
" "today": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Today.json?Category=pv-basic-rooms"," & @CRLF & _
" "yesterday": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Yesterday.json?Category=pv-basic-rooms"," & @CRLF & _
" "this_month": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/ThisMonth.json?Category=pv-basic-rooms"," & @CRLF & _
" "last_month": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/LastMonth.json?Category=pv-basic-rooms"," & @CRLF & _
" "daily": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Daily.json?Category=pv-basic-rooms"," & @CRLF & _
" "monthly": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Monthly.json?Category=pv-basic-rooms"," & @CRLF & _
" "yearly": "/2010-04-01/Accounts/ACd7a7c24a3c7b0b0ddcde452fd6c18aae/Usage/Records/Yearly.json?Category=pv-basic-rooms"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")