#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z\u00C1\u00C9\u00CD\u00D3\u00DA\u00DC\u00E1\u00E9\u00ED\u00F3\u00FA\u00FC\u00D1\u00F1]{1}[A-Za-z0-9\u00C1\u00C9\u00CD\u00D3\u00DA\u00DC\u00E1\u00E9\u00ED\u00F3\u00FA\u00FC\u00D1\u00F1\,\;\:\.@\#\$\%\&\* \-]+$"
Local $sString = "Éste es un regular expression creado para validar oraciones con caracteres de oraciones escritas en español. Puede ser utilizado para validar oraciones con vocales con acentos áéíóú, ÁÉÍÓÚ y u con diéresis Üü. No valida enters o líneas múltiples y tampoco oraciones con un espacio en el principio... por ejemplo. Aqui de romple la línea y se crea otra oración que parea con el regular expression..." & @CRLF & _
"" & @CRLF & _
"ésta es la nueva línea." & @CRLF & _
"" & @CRLF & _
"El guión - es otro caracter que está permitido en el regular expression, y las comas , como pueden ver también. Ojo, de la misma manera que no se permite el uso del espacio al inicio de una oración tampoco se permite el uso de comas , o quipnes al inigio de la oración ejemplos que no parean con el regexp a continuación..." & @CRLF & _
"" & @CRLF & _
"- esta oracion no hace match" & @CRLF & _
" ésta oración tampoco hace match" & @CRLF & _
", ésta oración tampoco" & @CRLF & _
"por el con trario... ésta - otra horación sí parea con el regex." & @CRLF & _
"" & @CRLF & _
"José Manuel Rivera" & @CRLF & _
"" & @CRLF & _
"El güiro mágico" & @CRLF & _
"" & @CRLF & _
"La máquina de guerra." & @CRLF & _
"" & @CRLF & _
"ÁÉÍÓÚÜ áéíóúü" & @CRLF & _
"" & @CRLF & _
"para que éste regex paree con párrafos, dene modificarlo cambiando el match del espacio por el scape character de los end of lines" & @CRLF & _
" - \s." & @CRLF & _
"" & @CRLF & _
"De esa manera el RegExp. parea con parrafos y multiples lineas igual que con tabs y otros tipos de end of line characters."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")