$re = '/[Ww]eb\s?[Ee]x/m';
$str = 'webex
Webex
WebEx
web ex
Web Ex
Web ex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);