package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\d*,+[1-9,]*\]`)
var str = `[1,2,3,4]gsfdgsfgs [1,2]fadfafa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}