$re = '/(?<=<).*?(?<name>\w+)=?(?<param>\w+)(?=>)/m';
$str = 'Sentence one<waitforkey=ok>
Sentence two<waitforkey=ok>
Sentence three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);