const regex = /(?<=[a-z])(?=[0-9]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-z])(?=[0-9]+)', 'i')
const str = `RO6781`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}