package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(n(a|ă)scut(a|ă)?)|((domiciliat(a|ă)?)|(domiciliul))`)
var str = `nascut la
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}