$re = '/[0-9]cat$/m';
$str = '1cat
2cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);