import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=version:\\s\\s\\s\\s\\s\\s\\s\\s)\\d+(\\.\\d+)+";
final String string = "filename: /usr/lib/modules/5.7.7-967.native/kernel/drivers/video/nvidia.ko\n"
+ "alias: char-major-195-*\n"
+ "version: 450.57\n"
+ "supported: external\n"
+ "license: NVIDIA\n"
+ "srcversion: CCB2AEF641D4CD7A82E48B3\n"
+ "alias: pci:v000010DEd*sv*sd*bc03sc02i00*\n"
+ "alias: pci:v000010DEd*sv*sd*bc03sc00i00*\n"
+ "depends:\n"
+ "retpoline: Y\n"
+ "name: nvidia\n"
+ "vermagic: 5.7.7-967.native SMP mod_unload\n"
+ "parm: NvSwitchRegDwords:NvSwitch regkey (charp)\n"
+ "parm: NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)\n"
+ "parm: nv_cap_enable_devfs:nv_cap_enable_devfs=0 or 1 (int)\n"
+ "parm: NVreg_ResmanDebugLevel:int\n"
+ "parm: NVreg_RmLogonRC:int\n"
+ "parm: NVreg_ModifyDeviceFiles:int\n"
+ "parm: NVreg_DeviceFileUID:int\n"
+ "parm: NVreg_DeviceFileGID:int\n"
+ "parm: NVreg_DeviceFileMode:int\n"
+ "parm: NVreg_InitializeSystemMemoryAllocations:int\n"
+ "parm: NVreg_UsePageAttributeTable:int\n"
+ "parm: NVreg_MapRegistersEarly:int\n"
+ "parm: NVreg_RegisterForACPIEvents:int\n"
+ "parm: NVreg_EnablePCIeGen3:int\n"
+ "parm: NVreg_EnableMSI:int\n"
+ "parm: NVreg_TCEBypassMode:int\n"
+ "parm: NVreg_EnableStreamMemOPs:int\n"
+ "parm: NVreg_EnableBacklightHandler:int\n"
+ "parm: NVreg_RestrictProfilingToAdminUsers:int\n"
+ "parm: NVreg_PreserveVideoMemoryAllocations:int\n"
+ "parm: NVreg_DynamicPowerManagement:int\n"
+ "parm: NVreg_DynamicPowerManagementVideoMemoryThreshold:int\n"
+ "parm: NVreg_EnableUserNUMAManagement:int\n"
+ "parm: NVreg_MemoryPoolSize:int\n"
+ "parm: NVreg_KMallocHeapMaxSize:int\n"
+ "parm: NVreg_VMallocHeapMaxSize:int\n"
+ "parm: NVreg_IgnoreMMIOCheck:int\n"
+ "parm: NVreg_NvLinkDisable:int\n"
+ "parm: NVreg_EnablePCIERelaxedOrderingMode:int\n"
+ "parm: NVreg_RegisterPCIDriver:int\n"
+ "parm: NVreg_RegistryDwords:charp\n"
+ "parm: NVreg_RegistryDwordsPerDevice:charp\n"
+ "parm: NVreg_RmMsg:charp\n"
+ "parm: NVreg_GpuBlacklist:charp\n"
+ "parm: NVreg_TemporaryFilePath:charp\n"
+ "parm: NVreg_AssignGpus:charp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}