$re = '/^(?=.+[0-9])(?=.+[a-z])(?=.+[A-Z])(?=.+\W).{8,}$/m';
$str = 'BriRocks1!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);