re = /^(?!.*\bresolutions\b).*$/m
str = 'monitors/resolutions
monitors/34
monitors/foobar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end